Rewind: The 1st LSI Website!

2008-05-16 9

Do you recognize the screenshot below? You do? Aw, come here and let me give you a hug! That means you’ve been around ever since the Lomographic Society International settled in its’ first web home, back in 1996. That’s twelve years ago!

Now that the website is currently undergoing a makeover, looking at these screenshots makes me smile. Look at all those pixel goodness! The white background! The simple navigation strip! Seems like we’re heading back to the roots, but several notches better, of course.

As I was reading your feedback re: the Beta site, some of you liked the clean look, while there are some who preferred the busier version. I understand both sides – clean and simple is good, but the crazy, colorful details of the old site gives the site a home-y feel. But since work is still in progress – for now we’ll have to hold our breaths ’til the new site is revealed … and enjoy this gallery!

written by shhquiet on 2008-05-16 #news #website


  1. reinertlee
    reinertlee ·


  2. vicuna
    vicuna ·

    Great vintage & macintosh look!!

  3. jazzgohan
    jazzgohan ·

    the first touching stuff for a while!

  4. jogintas
    jogintas ·

    have to admit it looks funny today, but so did i at that time ;D

  5. graefin
    graefin ·

    wow, cool!
    I must admit that I didn't even had internet back in 96...our first modem was bought in '98.

  6. jeepeng
    jeepeng ·

    it looks nice, still...1996, i was 12 years-old, can't afford a camera yet... :~(

  7. takezzo
    takezzo ·

    omg, is that Netscape 2.0??? i must have been using a 2400kbps modem on my powerbook 180 :P

  8. superlighter
    superlighter ·

    one year later I've bought my first LCA....snif snif...sweet moving memories.

  9. fookshit
    fookshit ·

    awww... 1996

    i was 14 at that time and was still using my 110 instamatic camera and know nothing of the internet.

More Interesting Articles