Petzval_header_october_2014
Have an account? Login | New to Lomography? Register | Lab | Current Site:
First film soup

First film soup

I souped thsi film. But whie drying it it stuck. So my Lc-a seemd to wind correct (the wheel turned nicely) but actually I was shooting doubles without knowing. After some 40 shots the roll came to an end. Actually only one third of the roll was exposed.

gauthierdumonde This photo was shot on film. Taken by gauthierdumonde with a Lomo LC-A loaded with Lomography Color Negative 100 (35mm) film (available in our Online Shop) in Gent, Belgium. These tags describe this photo: doubles, soup, and film. Date: 2013-02. This photo can also be found in the album First film soup.

6 comments

  1. devildi

    devildi

    looks nice ..... although there where just a few pics.. i like them all :-)

    over 1 year ago · report as spam
  2. gauthierdumonde

    gauthierdumonde

    @devildi Thanks. I will soup another roll and dry it properly :)

    over 1 year ago · report as spam
  3. gauthierdumonde

    gauthierdumonde

    @devildi Oops, but then I won't get these freaky doubles. Unless I put the roll in my broken Smena 8M

    over 1 year ago · report as spam
  4. mafiosa

    mafiosa

    Great album

    over 1 year ago · report as spam
  5. kangiha

    kangiha

    love these! Awesome colors, Cheers!

    over 1 year ago · report as spam
  6. ohlordy

    ohlordy

    Love the colours and accidents make the best shots!

    over 1 year ago · report as spam