Petzval_header_october_2014
Have an account? Login | New to Lomography? Register | Lab | Current Site:
LC-W at the River

LC-W at the River

Is it just me, or does the LC-W over expose everything?

mafiosa This photo was shot on film. Taken by mafiosa with a Lomo LC-Wide (available in our Online Shop) loaded with Kodak Elitechrome EB film (available in our Online Shop) in Calgary, Canada. These tags describe this photo: bow, river, ice, frozen, rocks, cobbles, snow, sun, sunny, winter, outside, outdoors, city, bridge, pathway, trees, vegetation, buildings, 35mm, colour, blue, grey, green, and white. Date: 2012-02-04. Time: Afternoon. This photo can also be found in the album LC-W at the River - Feb 2012.

7 comments

  1. lazybuddha

    lazybuddha

    You might be right, I don't have one, but EliteChrome always seems to overexpose and not just in my LC-A. Great album and colours anyway

    over 2 years ago · report as spam
  2. igmaro

    igmaro

    Great album !!!

    over 2 years ago · report as spam
  3. trw

    trw

    I don't know, but it's still a great shot!

    over 2 years ago · report as spam
  4. littlekoala

    littlekoala

    my LC-A also overexposes, but not always, and I don´t know why :S

    over 2 years ago · report as spam
  5. 134340

    134340

    mine is kinda as same as @littlekoala when use LC-A+ with EBX still dont know what happeneed :1 , u got great over album btw

    over 2 years ago · report as spam
  6. pangmark

    pangmark

    i think it's more the film as i have the same thing with my diana mini though that has a rather slow shutter for a sunny day

    over 2 years ago · report as spam
  7. af-capture

    af-capture

    really nice set my friend....I have seen other overexposed sets with the wide...but it may be the film as indicated above...great set anyway

    over 1 year ago · report as spam

Where is this?

Nearby popular photos – see more

Nearby LomoLocations