Have an account? Login | New to Lomography? Register | Lab | Current Site:
The trees have eyes...!

The trees have eyes...!

I bought this Nikon FA from a charity shop. Love the camera, but it's got an issue somewhere, most likely with the lightmeter, as it just doesn't seem to expose correctly in either P or A modes. This second test roll was shot exclusively in A (aperture priority) mode, with new batteries and a Nikkor 28-70mm 3.5-4.5D lens that works perfectly on my other Nikon bodies. The film and the lab are both ones I've used with great results before, so I conclude that the problem lies with the meter. The only other possibility I can think of is that the focusing screen, which is very heavily scuffed and marked, is somehow to blame, as I believe the lightmeter takes its readings through the screen. This would also explain why my shots are not as sharply in focus as I would expect them to be. If anyone has a K2-type Nikon focusing screen you could sell or lend me for another test roll, please message me.

buckshot Taken by buckshot with a Nikon FA loaded with Kodak Ultramax 400 (35mm) film in Ashtead, Surrey, United Kingdom. These tags describe this photo: plants, trees, nature, landscape, and gardens. Date: 2012-10-27. Time: Morning. This photo can also be found in the album Second Nikon FA test roll.

1 comment

  1. jean_louis_pujol

    jean_louis_pujol

    nice color!

    almost 2 years ago · report as spam

Where is this?

Nearby popular photos – see more

Nearby LomoLocations