wasserschloß glücksburg

30 Weeks, 30 Cams - Week 15: Horizon Perfekt:

I got this cam for my birthday during my holidays. Couldn´t wait to shoot my first roll though. Unfortunately two bad things happened:
1. During shooting this first roll the knob for rewinding the film just fell off somewhere. I think it was at the beach but I couldn´t find it anymore. Luckily Petra from the customer service is a blast so after only two days I got a new one send to where I stayed.
2. This is the most annoying thing!!! The adjustment of the wheel for the exposure time is/was crap without me noticing it so as you can see most shots are overexposed even though I used a lightmeter. What happened? If you set the exposure time to 1/125 it actually means you have an exposure time of 1/60. 1/250 means 1/125 and 1/500 means 1/250. I hate it. During my current roll by accident I turned the wheel further than 1/500 so I couldn´t see the mark anymore and noticed a "click"-sound which made me think "Please not!!!". Well, as you can see it is like I thought it is. I have 3 more rolls shot like this and I hope the bad weather I had makes them look OK. Anyone experienced the same thing with the Horizon?


  1. vici
    vici ·

    it has been my experience that when you cross-process film from the Horizon - it generally comes out very over-exposed. Faster shutter speed helps that problem.

  2. bloomchen
    bloomchen ·

    @vici: thanks for your message: even though my problem is a technical one or better even a production problem i will consider this when using the camera. sometimes the appertures don´t fit with my lightmeter so i have to think about exposure times and appertures.