This is your last chance to pre-order your Petzval Lens and get the special aperture plates included for free! With estimated delivery in August (or even sooner), don’t miss out on securing your picture perfect portrait lens!

Have an account? Login | New to Lomography? Register | Lab | Current Site:
Fuji Fujichrome 400 (expired 1990) X-PRO

Fuji Fujichrome 400 (expired 1990) X-PRO

A Fuji Fujichrome 400 (expired 1990) film I shot with my Lomo LC-A (made in the USSR) on a scattered cloudy day and then cross processed. I think I just shot it with my LC-A set on 400 asa and not even 100 or something as most people recommend when using expired 400 film. My local photostore gave me the developed x-pro film for free, 'cause they said the film was blank. They didn't take a good look I guess. This is actually on of the view shots that was left on the film after cross processing it. A lot of the shots where vanished (blank). I scanned the shot with my Epson V600 on 2400 dpi, using colour correction & ice technology, restoring most of the picture that was still left on the film.

jaasirlinger This photo was shot on film. Taken by jaasirlinger with a Lomo LC-A loaded with Fuji Fujichrome 400 film in Zoetermeer, Netherlands. These tags describe this photo: netherlands, expired, fujichrome 400, zoetermeer, lomo lc-a, expired 1990, construction, crane, and x-pro. This photo can also be found in the album Fujichrome 400 - Expired 1990! X-PRO.

No comments yet, be the first

Where is this?

Nearby popular photos – see more

This photo has been submitted to these competitions