This is your last chance to pre-order your Petzval Lens and get the special aperture plates included for free! With estimated delivery in August (or even sooner), don’t miss out on securing your picture perfect portrait lens!

Have an account? Login | New to Lomography? Register | Lab | Current Site:

One day I decided to do doubles with myself. Forgot to adjust the ISO setting to a higher stop ( or should be 400 in this case) and I don't know what happened but my first layer are not even showing up in most of the shots ha! Oh man...but anyways...that's how it goes sometimes :)

grazie This photo was shot on film. Taken by grazie with a Lomo LC-A+ (available in our Online Shop) loaded with Fuji Sensia 200 film in Los Angeles, CA, United States. These tags describe this photo: doubles, failed, green, fuji sensia, xpro, x-pro, cross process, cross processed, bright, summer, lomo, lomography, film, 35mm, and lc-a. Date: 2011-07. This photo can also be found in the album Failed doubles with graziella :) ( doubles with myself)- LC-A+ and Fuji Sensia 200.

6 comments

  1. modern_nmt

    modern_nmt

    love it.

    almost 3 years ago · report as spam
  2. cc-in-paris

    cc-in-paris

    nice album! you have some beautiful pics! definitively not a failure!!

    almost 3 years ago · report as spam
  3. suizidekid

    suizidekid

    nice album, nice colors !

    almost 3 years ago · report as spam
  4. wuxiong

    wuxiong

    Successful double work..<:)

    almost 3 years ago · report as spam
  5. i_am_four-eyes

    i_am_four-eyes

    Just Love it ! : )

    almost 3 years ago · report as spam
  6. ivan_the_terrible

    ivan_the_terrible

    I enjoyed the colors in this album

    almost 3 years ago · report as spam

Where is this?

Nearby popular photos – see more

Nearby LomoLocations