This is your last chance to pre-order your Petzval Lens and get the special aperture plates included for free! With estimated delivery in August (or even sooner), don’t miss out on securing your picture perfect portrait lens!

Have an account? Login | New to Lomography? Register | Lab | Current Site:

Tighten up your Split Cam, tighten up your pictures!

Unfortunately, the Split Cam's spool doesn't actually hold the film tightly enough for exposures to work...but do not despair, if you have some tape at home and 5 minutes, your Split Cam will be ready to go!

My first adventures with the Split Cam failed again and again until I realized that because of the camera’s cheap plastic construction, putting film through the spool as you’d do with other cameras isn’t enough- the spool just won’t hold on to it tightly!

Luckily, this is REALLY easy to fix! :)

All you’ll need:
- A Split Cam
- Film you want to load
- Tape
- A toothpick, sharp pencil or hair clip

Steps:
- Cut little pieces of tape so you’re ready when you need them
- Prepare to load the film by putting it on the left chamber
- Pull the film across to the spool on the other side
-** Instead of putting film through the spool opening, wrap it around the spool a little less than 360 degrees so your fingers can hold it
- Once the end of the film is wrapped around the spool, use the pieces of tape to hold it as TIGHTLY as possible around the spool. Use as much tape as you need!
- If it’s hard for your fingers to make the tape stick to the spool as it curves closer to the back of the camera, use the sharp end of the toothpick/pencil/hair clip.

**You definitely want to make sure the tape is well stuck to the spool, or it might complicate things and get stuck to your film when you’re shooting

Hooray! Your Split Cam is ready for some lomo moments! Now go out and snap to your heart’s content!

written by caromi

1 comment

  1. roonandbeks

    roonandbeks

    I'm confused about what the problem was? We've had some sweet shots from our split cam and the only problem was a light leak which was fixed with some black tape on the back.

    over 3 years ago · report as spam