Finally, We're Online - Feedback Please!


After some hard weeks of programming and designing, we are finally online with our newest version of Take a look around and please let us know of any bugs and your requests or ideas in the comments. As usual we are happy to hear from you. Thanks for your patience today, read all of you guys and girls tomorrow.

After some hard weeks of programming and designing, we are finally online with our newest version of Take a look around and please let us know of any bugs and your requests or ideas in the comments.

As usual we are happy to hear from you. Thanks for your patience!

written by recurving on 2009-04-22 in #news #relaunch


  1. mandashitley
    mandashitley ·

    The comment/rate should be on top, not the share button

    I'm sure we will all use the comment button a lot more than the share button

  2. ndroo
    ndroo ·

    Agree. The comment/rate should be the default instead.

    Btw ... there seems to be problems with the Lab. Doesn't show the tick when an album is selected and nothing loads in 'Selection'.

  3. majorted
    majorted ·

    I agree with the two comments below. Also, why has the liked feature been so diminished? Before it was a major part of a photo's feedback, now it looks like a side note.

  4. majorted
    majorted ·

    The other major problem I see is the site seems to randomize the order of the photos in the albums: when I check in the lab it says theyre in the order I made. I go back to the albums, and theyre still mixed up; could we get this fixed???

  5. mandashitley
    mandashitley ·

    I agree with the like feature comment. Also I've noticed that when you're looking at someone's album it no longer shows the count of photos (1/25) ... That was helpful, I hope it comes back.

  6. mandashitley
    mandashitley ·

    The lab looks really awkward. I think someone already said the lab is weird, it's true. It's very weird. You can't tell when you've clicked something except for on the right side your tags and info show up. Other than that I have had no luck getting lab to work for me.. I think I was going to say something else as well.. I love the size of the pics especially for panoramic and instax pics. Looks great. Oh yes, I was going to say that the pictures are certainly random. Sorry for all the comments.

  7. halfawakehaiku
    halfawakehaiku ·

    I agree love the size of hoizon photos and that all my articles are listed. recent entries on the magazine are mixed up with old ones tho.

  8. icuresick
    icuresick ·

    I could still see the "Register" button even when I'm already logged in.

  9. breakphreak
    breakphreak ·

    1. Comment/Rate and Share Article are kinda tabs that occupy the same place to save space. However, they are totally unrelated, usually "comment" is the text area (that should be visible by default - to encourage people to contribute their comments) and "Share" is usually a small button somewhere else. There can be even a toolbar like "Share | Like | Tweet" (3 buttons).

  10. breakphreak
    breakphreak ·

    2. - if I press "More activity" and then press on some picture then I am transferred to see that picture. However, after pressing "back" the "Load More activity" state is _not_ kept in the session, so that I'll see only the first bunch of "Activity" strip.

    Also, a good design idea is that if you have the "more" button, you should have "less" button as well (the opposite one).

  11. breakphreak
    breakphreak ·

    3. Same like (1) but about photos in the photo album

  12. breakphreak
    breakphreak ·

    4. Tried to click on "Settings" ( but was redirected to 404 Not Found page.

    5. Any chance to get e-mail notifications about the happening in my "Activity" strip? (Also it's written "LoadMoreActivity" - better to have a button like "Show More")

    6. Any chance to link the activity to Facebook (just like flickr)? When I upload something to Flickr, it is shown in the facebook, so my curious facebook friends can come to flickr and see it. Why not making them to come to :)

  13. breakphreak
    breakphreak ·

    7. the "Want to post something in event|blog|location" refers to some wrong parameter in the session. Reading this article (…) I've seen "Want to post something in EVENTS" (not it blog, that's a bit confusing, because "Magazine » BLOG » Finally, We're Online - Feedback Please!" is written). But when I've got to THIS page again (after seeing some location), I see "Want to post something in LOCATIONS". Also, you might want to unify the GUI elements per user action type to make the site more usable and user-friendly. Why "Leave comment" is a button and "want to post in..." is a link? (more examples could be given :)

  14. azurblue
    azurblue ·

    Hi ! Just give a glance this morning at the new site : first, it is very long, second I can't see all the pics...

  15. lomodirk
    lomodirk ·

    looks nice, but my Horizon (404) and Samuraix3.0 ("does not exist") albums don`t work and I agree with halfawakehaiku

  16. hewzay
    hewzay ·

    Looking good lomo crew....I like it a lot. The change over did seem to affect my password though...made me need to use capitals letters to log in.

  17. mephisto19
    mephisto19 ·

    i prefere having access to comment/rating-box rather than to share an article... and what is about the direction of the entries? wasn't there a vote long ago? some keyimages of albums changed. it is good to have more shots open in photo-section

  18. jaminsemirang
    jaminsemirang ·

    happy to have you back. I can not wait to check and surf, hahaha, hope every little things goes well, congrats!

  19. oldskool_rider
    oldskool_rider ·

    i dont like how it jumbles up the order of shots in your albums, so you cant have the one you want as the key image for that album.

  20. oldskool_rider
    oldskool_rider ·

    oh, and where's my avatar gone?
    i tried to re-upload it and it wont let me

  21. -a-l-b-e-r-t-o-
    -a-l-b-e-r-t-o- ·

    the most important thing...I CANNOT SEE ANY PICS...(internet explorer 7) entries are not in chronological order...

  22. -a-l-b-e-r-t-o-
    -a-l-b-e-r-t-o- ·

    the default should be the comment - rate this article box

  23. halfawakehaiku
    halfawakehaiku ·

    agrees with alberto also some photos that were commented on turn up empty when you click on them.

  24. jaalvarez
    jaalvarez ·

    I´m trying to upload a lomolocation ...
    The screen says:
    # TODO create.html.erb
    I can wait, of course !!!!
    Congratulations for the GREAT job you are doing!!!!

  25. -a-l-b-e-r-t-o-
    -a-l-b-e-r-t-o- ·

    When i click on an album after i can see just the preview of the first picture...and then when i click on it, i'm not able to see it...

  26. pila_
    pila_ ·

    we can't register any user or migrate account!

  27. pila_
    pila_ ·

    Comments on my photos that were written over the past 2 days have gone..

  28. thaiseb
    thaiseb ·

    The new version is veryyyy slow I think. The pictures take a very long time to appear.

  29. magdalenagabriela
    magdalenagabriela ·

    the "selection" site in lab won't load:( and I can't see my avatar, although it appears in album.

  30. jrjw
    jrjw ·

    ditto about the comment/rate box. i have never ever used one of those "share" things...
    and in the case of the magazine, wouldn't it make more sense to have this box below the comments so i can see the most recent comment directly above, without having to scroll up to the top to post a message and then down again?

    and as others have mentioned, i thought the "chronological order" won the vote ages ago - why are you reversing this to the illogical backwards format??

  31. vicuna
    vicuna ·

    Well, first of all, the global design is improved, and I like the fact that all contributions are written on my home, even if they're not in chronological order (what order is it??)

    I can't tell many things about lab and albums because it needs a lot of time to load and my computer starts to heat and the ventilator gets on....... :(((( but I noticed that the pictures in the albums aren't anymore in the order I wanted, ... :(( And in the "activity" section, the pictures "liked" or "commented" aren't showing up... and I'm missing the numbers of the pics in the albums...

    Then, as others, I think the "comment/rate" should be the default setting, not the "share"... and as mephisto says, about the order of comments (top= recent comments) was submitted to a vote to have the chronological order (top= older comments) and now it's reversed...

    These are really just my first impressions, must have a closer look to all the new features, but it's really slow by now.... but I'm sure that all this will be fixed very soon! :)))

  32. vicuna
    vicuna ·

    I like the new banners on the top pages (cool to see new banners...;) and it's really cool to have much more photos in the "most popular" photo section... :)))

  33. vicuna
    vicuna ·

    bigger thumbnail pictures for the different magazine entries are cool too! :)

  34. mephisto19
    mephisto19 ·

    ì have no access to new uploaded pictures and it is veeeeery slow

  35. breakphreak
    breakphreak ·

    8. the "search magazine" and "What are you looking for" text lines that we are supposed to type our search terms in => those text lines are NOT auto-cleaned/auto-selected upon receiving a focus. Moreover, the "search magazine" text cannot be selected at once, so every time I need to type the text in I need to use the "delete" button to clean that text. Yep, still looks like a beta testing stage :)

  36. eyecon
    eyecon ·

    I like what I see, but there seems to be still some bugs to be fixed.

  37. eyecon
    eyecon ·

    ....and it is still superslow.

  38. inotion
    inotion ·

    i have problem with my lab too.

  39. rater
    rater ·

    Do not have much time right now to explore the new web, but here are two comments:

    With at least one of my albums, when I click on it i get a page with message: The page you were looking for doesn't exist.

    Also, the comment/rate feature should be default, not the share as we use more the former than the latter... I think this is a common feel with other lomographers.

    Nice thing to get more photos in the photos section!

  40. rater
    rater ·

    Oh, and photos take a long time to load! Even the thumbnails!

  41. lomodirk
    lomodirk ·

    Lab: uploading seems to work but I can`t see which folders are selected (check is missing) and I can`t open "selection". But beta is faster than hours before ;)

  42. halfawakehaiku
    halfawakehaiku ·

    I cant submit photos to the rumbles. the submit tab doesn't have any option to upload photos

  43. dogma
    dogma ·

    After changes in DB key images of all my albums are massed up. Should i change them back or they will be fixed automatically?

  44. xbalboax
    xbalboax ·

    besides the site running slow, im pretty happy with it, i agree that comments should be on the bottom of the page. love how the horizon shots look now. gonna start testing, will let you know.

  45. thaiseb
    thaiseb ·

    I don't have access to new uploaded pictures.

  46. deff1
    deff1 ·

    Really liking all the new features on the site, fantastic! Only one thing, sometimes when you click on a album you get a message saying it does'nt exist. apart from that i like everything!

  47. vicuna
    vicuna ·

    The size of the pictures as shown in the albums, specially the Horizon ones, is really great!!

  48. rater
    rater ·

    I have to agree... the new size of the Horizon photos is awesome!

  49. mephisto19
    mephisto19 ·

    the style of the letters changed.... sometimes. it is harder. i prefere the softer version

  50. bongofury
    bongofury ·

    where's my avatar ? i tried to re-upload it and it wont let me

  51. xbalboax
    xbalboax ·

    error: server does not respond - when uploading photos

  52. mephisto19
    mephisto19 ·

    i like the new upload function and that you can filter more than one tag the same time BUT it always goes back to all shots and does not leave the filter, so i have to filter again and again after submitting a shot

  53. hhjm
    hhjm ·

    new beta very slowly some pics in my competitions , activity disappear!!!!! can't upload my avatar too.

  54. lizzsunn
    lizzsunn ·

    I like the look, but I can't see any pictures, the site is super slow, my lab is messed etc. etc.

  55. disdis
    disdis ·

    I like a lot the new layout. It's more useful but... as always there's a "but", a lot of pictures and avatars cannot be seen. Even I cannot change my settings or upload new pictures.

  56. xbalboax
    xbalboax ·

    i cant create albums or add location info to the photos in the lab

  57. trash-gordon-from-outer-space
    trash-gordon-from-outer-space ·

    I am still missing the possibility to search for tags just in my own home. Or have I overlooked a way to do this?

  58. cinzinc
    cinzinc ·

    it's taking forever just to organize the photos i've just uploaded. Would've been nice to add the shop section in this site rather than being redirected to What else? Let's just see after a few more days.hehe.

  59. xbalboax
    xbalboax ·

    it seems like the albums get created but the photos dont move into them when selected. btw im using safari and firefox to check the site

  60. eggzakly
    eggzakly ·

    Like so many others, my avatar seems to have gone missing. I was able to upload pictures in my lab, but unable to select any albums.

  61. maddyoulook
    maddyoulook ·

    a ton of my photos are x's now..

  62. mandashitley
    mandashitley ·

    I know I have already left plenty of comments and that a lot of this stuff is being repeated, and I'm sure you guys will make your way to fixing things as fast as you can, but I have to agree with some..
    I see that you have already changed the default setting to be Comment/Rate... THANK YOU!! I am already very much relieved.
    The smaller size of the Ads on the top of pages is hard for me to get used to but when they were bigger it annoyed me to no end! So I am sure that will also grow on me (although I thought the old ads looked nicer [no offense to the persons who created these]).
    Almost no albums/links to albums are working for me (some do but it is very random). Right now I can't click on any photos, they do not load at all anymore. I mean, everything on the photo page loads except for the photo. (mozilla I love you, my internet died in the middle of typing this and it is all here when I get back on). I haven't even bothered uploading or trying to fiddle with my lab, I don't think it would be worth the troubles right now so I am waiting it out. :/ o.0 :(
    I do like how you've changed the order on the Photos page, The popular/recent uploads/submissions being on top and the tags/camera/film/location underneath.
    I agree with the comment about having to delete the contents of "search magazine" before you can type (but that only happens if you don't click and immediately type what you want there, if you click it in a wrong way that is when it doesn't work properly)
    What else... I wish there were an easier way to get to Lab. Maybe it could go Lomograpghy | About | Shop | Photos | Mag | Homes | Lab? Or Maybe where it says "Hello mandashitley | *settings | logout you could add a link to lab there? Idk I just wish I didn't have to go to my home/homes to get to the lab. (my home/homes page takes a while to load sometimes so I'd like to be able to bypass that)
    One more thing, I also agree with the reversed order of the comments, I liked it much better the old way, It is a bit confusing now, and you have to scroll to the bottom to leave a comment anyway. (I think I liked it better the old way than the suggestion of putting the comment box at the top)
    You guys are doing a fantastic job, keep it up, we love you for it (even though it's a bit rough right now).

  63. hhjm
    hhjm ·

    Can't delete selected albums(0 images) its shown Something went wrong!!!!

  64. butchcomer
    butchcomer ·

    The albums & photos in my home are not viewable. Everything just seems to be x's right now. I hope everything gets fixed soon. Other than that, I think it's going to be fine.

  65. janette
    janette ·

    Oh Sorry, I should have posted my comment here and not on the news feed. I can't see any pictures in my Beta Home, just the shell!
    Big lomo love
    janette :-(

  66. halfawakehaiku
    halfawakehaiku ·

    When I'm logged in I cant view my own photos An error message comes out. Like the one I submitted for the Matador rumble for example. But when I'm not logged in the image displays correctly,

  67. xbalboax
    xbalboax ·

    Service Temporarily Unavailable

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Apache/2.2.9 (Debian) Server at Port 80

    i get this when i try to search the blog, go to the competitions 2 and when i go past page 4 on the blog page.

  68. eggzakly
    eggzakly ·

    Ok, I was now able to organize the photos I uploaded last night into albums, but it seems like it's no longer possible to pick which photo to use as thumbnail. The thumbnail that was randomly chosen for my new album was vertical and very long and completely illegible on the public feed. Also, still having avatar-problems (obviously :)

  69. hhjm
    hhjm ·

    Can't go my home after login with my account.

  70. migueld
    migueld ·

    testing on firefox:
    1. my key images for album thumbnails all got reset! lots of work ahead for me...
    2. thumbnail-size images are coming up way slow.
    3. the 'loadmoreactivity' state isn't saved when i hit the back button, so i have to keep hitting the loadmoreactivity button again just so i can go back to where i was
    4. hitting 'settings' on my home leads me to an error 404 page
    5. lab works fine!
    6. # TODO create.html.erb shows up if i want to submit a location, film, event, or blog entry (in fact in most parts of the magazine that have a submit function this little ditty shows up)
    7. clicking on a tag redirects me to a 'missing page' and searching a tag is kind of useless right now

  71. jco405
    jco405 ·

    I love not having to resize all of my images! And I'm so glad I can upload more than five at a time. Thanks!

  72. kylewis
    kylewis ·

    OH! I do so hate moaning but I cant see my photos and especially ALL the recent uploads. Even when I open my old albums I get the wheel of death or a ? for my effort. This is so cumbersome now as a site, I read below that some can upload more than one pic 5?! I cant what is that about?
    It's great not having to resize everything but if it means waiting this long it is not worth it.
    I use Safari or Firefox and its the same on both with a Mac 10.5.6.
    Please help I want to enter competitions! It's making me SAD ;((

  73. kylewis
    kylewis ·

    I forgot to say I love the size of my new ?????? marks on the Horizon shots.....when I see them!
    keep up the good work

  74. hhjm
    hhjm ·

    We're sorry, but something went wrong… We've been notified about this issue and we'll take a look at it shortly. Here are some links that should work in the meantime:!!!!!!!!!!!!! shown me all time when I'm login to my betahomes.

  75. thaiseb
    thaiseb ·

    Now I can tag my pictures, but all my albums can't be seen on my lomohome.

  76. thaiseb
    thaiseb ·

    Ok, I understood the problem : can't use / in the albums names.

  77. mephisto19
    mephisto19 ·

    maybe a addition to a keyimage (like in the old homes) would help and not only the position. so yo wouldn't have to change the order of the shots

  78. mephisto19
    mephisto19 ·

    maybe a addition to a keyimage (like in the old homes) would help and not only the position. so yo wouldn't have to change the order of the shots

  79. spendospend
    spendospend ·

    like the old home a place to enter your home to be chosen to be BHOTD, feels like you would have more of a chance :) i cant seem to get mine to get noticed :(

  80. eggzakly
    eggzakly ·

    Ok, I'm getting an odd error when adding metadata in the lab now: when I type in the film type, i.e. Fuji NPC (220, 160 iso) and hit "enter" (or click "save"), all that's saved is "iso". I've tried typing in a few different film types and it happens with all of them. If I pick one of the choices that appear while typing it doesn't happen, though. Glad to have my avatar back!

  81. ivanvano
    ivanvano ·

    really nice picture

  82. threemoons
    threemoons ·

    Okay, moving things between albums in lab just. does. not. work. Too complicated. I would upload a lot more and use the Lab a lot more if it actually worked. YES I WATCHED THE TUTORIAL VIDEO. I CANNOT open an album and have the other albums show up in the page to drag and drop to, end of story. :(

  83. herbert-4
    herbert-4 ·

    I am noting very many broken links. Look at "cameras" and "films" especially. Also, uploads will randomly freeze that browser window but not OS, necessitating closing that window (senile computer with Win2k and IE6, unfortunately). Beta has a general feeling of FUBAR. Please fix. Thanx.

  84. superlighter
    superlighter ·

    sorry...don't work at all!!!!

  85. tnzzz
    tnzzz ·

    Sorry, but like others I'm having problems as well. I think my biggest peeve is the load time for thumbnails. Some of mine don't ever finish loading. Also, the lab runs insanely slow when loading my albums, etc. This wasn't a problem with Beta until the new changes were made...

  86. tnzzz
    tnzzz ·

    Another issue; Can't upload photos. Get a 'Server Does Not Respond' error... sad :(

  87. mandashitley
    mandashitley ·

    general idea because I am forgetful. but it is not you guys' fault that i am forgetful so maybe i should work on that myself lol.. but maybe when you click on someones home to leave a message it should already be not public, since you clicked their home to leave it... just an idea. or make it so that we can send each other private messages. or maybe i should have just used my cell phone.

  88. mandashitley
    mandashitley ·

    option to delete comments we have made

  89. azurblue
    azurblue ·

    locations still not working :((((

  90. dixie_flatline
    dixie_flatline ·

    in my home the links to my album and photos doesn't work.

  91. dixie_flatline
    dixie_flatline ·

    don't tell me I must re-upload everything, please!

  92. thaiseb
    thaiseb ·

    I can submit pictures to competitions or articles, but the links are all broken… In my albums, the links are ok…

  93. mephisto19
    mephisto19 ·

    my pics are not displaied in photo-section after someone left a comment

  94. mandashitley
    mandashitley ·

    how come the "most active users" has been exactly the same since the relaunch? is it cause you are the guys fixin' everything?? i'm just curious. i miss how it used to be

  95. migueld
    migueld ·

    i want to submit so many things LSI but the site won't let me!!!!

  96. tsnsak
    tsnsak ·

    thanks for all the work. my home is having issues w/ randomly selecting key images...won't change even when I change the order...which I'm not always able to do anyway : ) [another problem] Sometimes the thumbnails load...other times not. I run the firefox 3. something 9the most recent) and the newest vs. of safari on mac os 10.5.6. Oh...and moving pictures w/in albums and to other albums is pretty hit or miss. thank you.

  97. mandashitley
    mandashitley ·

    whenever i click the shop link it always opens up two new shop windows instead of one. is this just me?

  98. ttrsgirl
    ttrsgirl ·

    i can't edit my profile for some reasonnn :(
    but thanks for all the hard work!

  99. jelga
    jelga ·

    hi! i use a macbook pro and a pc (with vista...hugh!) and i dont seem to be able to see any pictures in the new site....i dont know if they're somehow blocked or if it just takes forever....
    in any case it's very frustrating!!
    ps plus it would be very nice if we could assign one picture to different albums as supposed to just one! thanks for the efforts and the hard work !

  100. threemoons
    threemoons ·

    Guys--Organizing photos in the lab is just not working. I CANNOT get two albums to display as "open" on the same screen like it shows in the tutorial video.


    It would also be really nice if someone actually responded to the @beta email address.

  101. mandashitley
    mandashitley ·

    1. So I was thinking that when you tag things, some of us do not capitalize our words, so we end up making two of the same tags. Ex: Fisheye and fisheye. When you search the tags for fisheye, instead of bringing up just one tag for Fisheye, it shows both. That was a bad example. There's like a hundred or more different fisheye tags. I feel bad for all of my crazy tags now. Is there some way words, no matter their capitalizing, would just create one tag? 2. Also, when I am in the lab tagging my photos it always auto finishes my typing. And it 99.9% of the time finishes them wrong. And I am not paying attention to the page when this happens, so I end up getting someone's username in my tag instead of say the word...... scooter... i would get scootiepye. That is just one example... It kind of reminds me of cell phones & texting with T9. And then I get an unnecessary wave of frustration. Kind of like when you guys read these suggestions...................JK! I hope we are not that annoying. But we sure do put you to work huh?

    That last comment about the shop link has been fixed for me, so if that was your guys' doing, kudos. Have a fantastic day, evening, brunch, morning, whatever time it is on your side of the world.

  102. disdis
    disdis ·

    My avatar cannot be changed

  103. threemoons
    threemoons · and interesting bug. Viewing 2 albums at once working, but any changes made to album not staying. Wasted all afternoon uploading almost 100 pix and when I logged in again..nada. GRRRRRRRRRRRR.

  104. mandashitley
    mandashitley ·

    For people with a lot of articles published (ex: wil6ka) it might be more visually appealing if the article links had two or more (if necessary) columns on their home page. Or perhaps an expandable/retractable (maybe even drop down) list of their articles written. Which is not to say that their articles shouldn't be showcased, they just make the pages much longer. And from now on I am going to try really hard not to have any more suggestions. <3

  105. dixie_flatline
    dixie_flatline ·

    1) The links to my albums are still broken. I've tried to make them private and public again, but nothing.
    2) I can't edit my home: the link to the edit page is broken too

  106. herbert-4
    herbert-4 ·

    I tried to do a review of a Fedka and discovered that my photos for the review that have a 768 pixel side are "too small" to upload. They meet the rule and I have been uploading before to beta. This is a diriment impediment to the usefulness of beta and needs to be fixed ASAP. The bugs are becoming a swarm of locusts. Thanx

  107. dixie_flatline
    dixie_flatline ·

    thanks LSI, problems in my home are solved

More Interesting Articles