Have an account? Login | New to Lomography? Register | Lab | Current Site:

For some reason all or most of the pictures have this really weird light leak right in the middle of every photo... and it's the LC-A+ it never produces light leaks... anybody have a clue of what might be wrong?

reneg88 This photo was shot on film. Taken by reneg88 with a Lomo LC-A+ (available in our Online Shop) loaded with Kodak Ektachrome VS (35mm, 100iso) film in San Juan, Puerto Rico. These tags describe this photo: splitzer, multiple exposure, double exposure, feet, lomo, lomography, light leak, light leaks, puerto rico, reneg88, slide, cross process, beach, burn, film, ektachrome, lc-a, ocean, blue, water, and sky. This photo can also be found in the album .Light Leaks Freak..

29 comments

  1. mylatehope

    mylatehope

    Godly!

    over 3 years ago · report as spam
  2. kylethefrench

    kylethefrench

    where you been hiding man? great welcome back photo

    over 3 years ago · report as spam
  3. werriston

    werriston

    Great.

    over 3 years ago · report as spam
  4. lightblue

    lightblue

    wow!

    over 3 years ago · report as spam
  5. lisi

    lisi

    love it!

    over 3 years ago · report as spam
  6. bulletofmine

    bulletofmine

    intentional light leaks or what?

    over 3 years ago · report as spam
  7. boredbone

    boredbone

    wicked colors

    over 3 years ago · report as spam
  8. dakadev_pui

    dakadev_pui

    สุดยอด superb!

    over 3 years ago · report as spam
  9. isoterica

    isoterica

    Maybe that particular roll of film was damaged in some way or.. exposed when you took it out of the camera so that it made the same footprint. How was the next roll?

    over 3 years ago · report as spam
  10. mightymouse

    mightymouse

    NIce

    over 3 years ago · report as spam
  11. satire

    satire

    woww expect unexpect
    over 3 years ago · report as spam
  12. dimitrul

    dimitrul

    muy chula!!

    over 3 years ago · report as spam
  13. mikahsupageek

    mikahsupageek

    ONE FOR THE BOOKS !!!

    over 3 years ago · report as spam
  14. kristianj

    kristianj

    SICK GOOD!

    about 3 years ago · report as spam
  15. kristianj

    kristianj

    SICK GOOD!

    about 3 years ago · report as spam
  16. jetnz81

    jetnz81

    Look funny >.<

    about 3 years ago · report as spam
  17. senjamencerna

    senjamencerna

    totally kick ass :)

    about 3 years ago · report as spam
  18. parsifal85

    parsifal85

    wooo great

    about 3 years ago · report as spam
  19. chikiu

    chikiu

    increible!
    almost 3 years ago · report as spam
  20. welland

    welland

    Rad

    almost 3 years ago · report as spam
  21. murdoc_niccals

    murdoc_niccals

    "anybody have a clue of what might be wrong?" no no... my dear friend. everything is just right! :) stunning picture.

    over 2 years ago · report as spam
  22. coastal_lauren

    coastal_lauren

    I love this! It looks so freaking cool :p

    about 2 years ago · report as spam
  23. sobetion

    sobetion

    Great!!

    about 2 years ago · report as spam
  24. disdis

    disdis

    I love this picture. Would you like to add it to the shoes/feet fetish collection?
    http://www.lomograph(…)feet-fetish

    about 2 years ago · report as spam
  25. lighthouse_keeperess

    lighthouse_keeperess

    great idea!

    about 2 years ago · report as spam
  26. lakritz

    lakritz

    WOW

    about 2 years ago · report as spam
  27. simonesavo

    simonesavo

    Great!!

    about 2 years ago · report as spam
  28. peacocksky

    peacocksky

    I love this.

    almost 2 years ago · report as spam
  29. venus_in_stripes

    Hi-Know what the issue might be with your camera. Sometimes the back of the camera isn't closed, just enough so light can leak onto the film. I would suggest you take it to a camera repair man to look at.
    almost 2 years ago · report as spam