Have an account? Login | New to Lomography? Register | Lab | Current Site:
LCA + Wide Angle

LCA + Wide Angle

I think there is some problem with my LCA Wide Angle Lens add on. Everything seems like a zoom burst and i don't know why

illegaltender This photo was shot on film. Taken by illegaltender with a Lomo LC-A+ (available in our Online Shop) loaded with Kodak Ektar 120 film in Singapore, Singapore. These tags describe this photo: singapore, happy, time, friend, food, fire, works, fireworks, lca, wide, ektar, and 100. This photo can also be found in the album LCA WIde Angle Lens.

6 comments

  1. jim721217

    jim721217

    are you sure this is LCA Wide Angle Lens ?

    almost 2 years ago · report as spam
  2. illegaltender

    illegaltender

    @jim721217 Yes it is :( I think there is something wrong with it and is out of warrenty so the lomo store would not cover it :(

    almost 2 years ago · report as spam
  3. kylesherman

    kylesherman

    Looks like the tunnel vision one mate.

    almost 2 years ago · report as spam
  4. illegaltender

    illegaltender

    @kylesherman I know dude. I suspect that lomography has accidentally put a tunnel vision lens in a wide angle box. haha

    almost 2 years ago · report as spam
  5. kylesherman

    kylesherman

    Ahhh man! Still, really good pic!

    almost 2 years ago · report as spam
  6. ooblue

    ooblue

    i know what problem with you lca wide angle lens , the third lens installed backwards .

    2 days ago · report as spam