Community_cup_july_2014
0 : 5

Monday 12:00 CET to Tuesday 12:00 CET – Build 5 LomoWalls which represent your love for analogue – Reward: 5 Piggies

0 : 1

Tuesday 12:00 CET to Wednesday 12:00 CET – Write a blog entry about why you love analogue photography – Reward: 5 Piggies

0 : 50

Wednesday 12:00 CET to Thursday 12:00 CET – Upload 50 Photos - Reward: 5 Piggies

0 : 1

Thursday 12:00 CET to Sunday 21:00 CET – Who do you think will win the huge climax to the football fiesta in Brazil? Take a lucky strike and make your guess in our magazine article - Reward: 10 Piggies

Have an account? Login | New to Lomography? Register | Lab | Current Site:
Film Mistake

Film Mistake

I thought I had Fuji Provia 100 film in the camera. I was planning to cross process. I shot the film using 100iso setting. I was very surprised when I opened the camera and found 400 B&W. It took a while to find somewhere to process it locally too b/c it was professional B&W.

pearlmsqueaks This photo was shot on film. Taken by pearlmsqueaks with a Pentax K1000 loaded with Kodak TMax 400 B&W TMY film in Hadlyme, CT, United States. These tags describe this photo: hiking, gilletts, castle, black, white, and woods. Date: 2012-09-01. Time: Afternoon. This photo can also be found in the album Hiking at the Castle.

1 comment

  1. koduckgirl

    koduckgirl

    Even tho you had the iso wrong these are still quite worthy and I like all the detail you got its a neat place! And thanx for your likes!

    over 1 year ago · report as spam

Where is this?

Nearby popular photos – see more