Have an account? Login | New to Lomography? Register | Lab | Current Site:
My lightmeter broke so I endep up guessing blues and greens

My lightmeter broke so I endep up guessing blues and greens

The leftovers from my trip to Italy

blablabla-anab This photo was shot on film. Taken by blablabla-anab with a Minolta x-300s loaded with Kodak Ektachrome E100GX film in Venezia, Italy. These tags describe this photo: minolta, x-300s, kodak, ektachrome, e100gx, blue, slide, xpro, 35mm, and italy. Date: 2012-04-29. Time: Night. This photo can also be found in the albums #36 Minolta X-300s / Kodak Ektachrome E100GXViagem a Itália 27-30 Abril 2012.

6 comments

  1. adash

    adash

    WOW!

    over 2 years ago · report as spam
  2. maduz

    maduz

    lightmeter not functioning? ended up in an awesome picture! :D

    over 2 years ago · report as spam
  3. lauta85

    lauta85

    Me recuerda a algunas pinturas de Van Gogh, buenísima!
    over 2 years ago · report as spam
  4. herbert-4

    herbert-4

    Excellent!! About your camera's light meter, she's a common camera, and parts can be found, easily. Camera Max is who I have employed to repair my Minolta SR505. It was US$55 labour and CLA + US$24 for a new light meter module, making her new. http://cameramaxrepa(…)ervices.asp Harry is the proprietor, and he and his technicians can fix anything! This is very far from you, though. I'm in California.

    about 2 years ago · report as spam
  5. rbruce63

    rbruce63

    Outstanding!

    about 2 years ago · report as spam
  6. blablabla-anab

    blablabla-anab

    @herbert-4 I'm so sorry, I forgot to reply. Thank you for the information :) It just so happens that I'm lucky enough to have a Camera Mechanic across the street. I found the shop just when I needed it. :)

    @rbruce63 thank you :)

    about 2 years ago · report as spam

Where is this?

Nearby popular photos – see more

Nearby LomoLocations

This photo has been submitted to these competitions